Summarize

写在前言:

首先欢迎大家光临60addons和感谢一直以来对本站的支持,我们是一个纯wow香草爱好者所建立的插件资源站,网站所有资源功能围绕60年代魔兽所开发和汉化,致力于让更多热爱60级怀旧魔兽爱好者体验到更多更好更新的插件资源!

本站站长兼技术主编: Qcat



一、插件如何安装

第一步:完全退出你的魔兽世界客户端,一定要大退,小退是没用的。

第二步:下载你想安装的插件,大多数情况下你下载的是压缩包文件,如.zip和.rar的文件

第三步:提取文件,通常称为“解压缩”,每个单体插件的解压包里一般为一个文件夹,解压他到你的 Interface > Addons 文件夹内。

第四部:安装完成!开启魔兽世界,确保插件的安装,你可以登录到人物界面,点击左下角的>插件<按钮查看。

*建议:为确保插件的完全使用,建议大家把"加载过期插件"打钩,并且在脚本内存栏里的数字修改成"0"或者"999"

           

二、基础

1:所有插件必须放入你的 World of Warcraft > Interface > Addons 内才能生效

2:插件文件夹的名字必须是以他的.toc名字为基准.如插件文件夹名字和他的.toc名字不对等,则插件无法生效

3:本站所有插件80%以上都已脱库,可不必依赖于公用依赖库。

4:站内所有插件的兼容性都经过初步测试,基本不会出现兼容性报错无法使用。

5:除本站外,所有插件站内的插件如果出现报错无法使用,本站一概不予解释。

三、建议与标准

由于本站所有插件都是基于外服E服核心所汉化,所以一切的汉化标准都是基于外服中文端,我所给出的建议如下:

1.最新依赖库是基础的基础,站内的最新依赖库适用于所有60年代各种核心端,此插件为必装! 链接:依赖库

2.由于站内大部分插件都是基于外服端,在玩国内非E服端核心的玩家可能会出现个别插件功能性缺失.

3.由于本站的依赖库是本人最新修改汉化修正的,所以为了防止可能的报错和兼容性问题,建议大家所有插件整合搭配都在本站完成。

4.本站插件由于一直在更新完善,会出现插件新老版本更替的情况,建议大家实时关注自己所喜爱的插件。


四、常见问题与解决办法

问:我的插件报错了,怎么解决?

答:插件报错的原因有很多种,可能是插件本身原因,可能是你自己在使用过程中的错误操作,可能是字体缺失,可能是你有冲突的插件。我的建议就是:首先从自身找起,你的依赖库是否安装正确?老的库是否删除干净?字体文件夹是否文件齐全? 插件安装路径是否正确?

问:我的插件怎么只有框,里面没有字?

答:在我的大部分插件里,我是没有给他的字体转向到本地默认字体的,所以部分插件作者所指向的字体文件可能不会出现在中文客户端里,所以你需要一份字体文件夹齐全的字体让他支持插件 点击字体寻找一份你喜爱的字体复制到你的魔兽根目录下。

问:为什么有些插件我找不到他的设置?

答:绝大部分插件都有他的设置命令,这些命令我在都插件的详情页最下方给予标注;也有些插件本身自带小地图按钮支持,有可能是你的小地图图标太多,被挡住了,建议安装一款小地图图标整合插件可以更好的管理你的插件

问:为什么我的插件无法工作,出现依赖缺失?

答:个别插件必须依赖另一款,或者几款插件才能正常工作,如果出现依赖缺失现象,首先查看该插件需依赖哪些插件,如果是需要依赖Ace ,Ace2 ,!!!libs这类的,首先你必须下载安装本站的最新依赖库,然后找到问题插件的文件夹,把该文件夹内的.toc后缀名的文件用记事本或者word打开。找到和删除里面的Ace ,Ace2 ,!!!libs 字样。

问:为什么我的插件出现版本错误?

答:每款插件的.toc文件里都有对应的版本号,如:## Interface: 11200 。后面的数字对应支持的客户端的版本。60级最高版本为11200 ,所有非11200的数字都会造成你在游戏里的版本错误,解决办法就是修改版本号,或者是在游戏里的选择人物界面左下方的<插件>里把<过期插件>勾选。

问:同类型同功能的插件可以一起用吗?

答:具体要看什么插件,有些插件支持同功能的插件一起用,是因为2款插件未发生字段变量冲突,但更多的插件是不支持同功能的插件同时用的,如果出现报错,请禁用或删除一款相同功能插件。

问:我用了UI类的插件,该怎么搭配我其他的插件呢?

答:60年代的UI类插件屈指可数,也就那么几款,目前大型的集成类UI插件有:PFui(原shaguui),modui,SUI,这3款是最有代表性的集成类UI插件。集成也就代表功能繁多,所以在其他插件的挑选上必须更加的仔细,否则很容易出现插件冲突,报错,无法使用。我的建议就是:如选择大型集成类UI插件,就尽量围绕该插件挑选其他辅助插件,尽量避免有于该UI功能相同的单体插件!

问:我的插件也没报错,也载入了,之前还能用,现在怎么不能用了?

答:这种情况唯一的可能就是WTF问题,wtf是你的插件设置,各种账号设置的文件夹,插件如果出现非插件功能性问题,一般问题都出自你的WTF文件上,解决办法就是:在你的魔兽根目录下,找到WTF文件,搜索该文件夹内的所有于你报错插件有关的文件,找到并删除!切记一定要在游戏大退后。WTF的文件夹里插件部分分为全局文件夹,和具体账号人物插件设置文件夹,2者如果都有问题插件的文件,都要删除。


                                                                                                                                       By Qcat

                                                             本向导最终解释权归60addons所有